Excel: Indice() y Coincidir() para encontrar el valor de una intersección

Valor de una intersección de fila y columna

En ocaciones nos encontraremos con un problema en excel, donde necesitaremos encontrar el valor de una celda en una intersección de una fila y una columna. En este caso no nos servirán las formulas ni de consultav() o consultah(); si no mas bien debemos hacer el uso de dos formulas de excel en conjunto. Estas son: la funcion INDICE() y la función COINCIDIR().

La función INDICE()

Esta función sirve para obtener el valor de una celda en una matriz, según el número de columna y el número de fila
=INDICE(matriz_buscada ; num_fila ; num_columna)

Ejemplo:
Si tenemos la siguiente matriz de Excel
Las fórmulas
=INDICE(A1:C2;2;2) me entragará sol
=INDICE(A1:C2;1;3) me entragará pasto

La función COINCIDIR()

Esta función entrega la posición en la que se encuentra un valor dentro de una matriz unidimensional
=COINCIDIR(valor_buscado ; matriz_buscada ; tipo_de_coincidencia)
El tipo de coindicendia: 0 para obtener valor exacto

Ejemplo:
Si tenemos la siguiente matriz de Excel
Las fórmulas
=COINCIDIR("cliente 3" ; A1:D1 ; 0) me entragará 3
=COINCIDIR("cliente 2" ; A1:D1 ; 0) me entragará 2

Utilizar ambas para encontrar el valor de la intersección

Para poder utilizar ambas funciones en conjunto para encontrar el valor de una celda en una intersección de una fila y una columna, debemos hacerlo de la siguiente manera:
Como función principal usamos INDICE() la cual le diremos que dentro de una matriz me indique el valor de una celda. Para indicarle a INDICE que fila y columna utilizar, debemos usar COINCIDIR(), la cual nos entregará la posisión de la fila y columna.

Supongamos que tenemos 4 departamentos y sus gastos categorizado por agua, electricidad y otros. Tenemos los gastos en la siguiente tabla de excel:
Para poder encontrar el gasto de electricidad del departamento 802A debemos utilizar:
=INDICE(B2:E4;COINCIDIR("electricidad";A2:A4;0);COINCIDIR("802A";B1:E1;0))